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|.1 Creating User
Accounts



Software Update. ..
App Store. ..

Dock »

Recent Items »
force Quit Finder L OXD

Sleep
Restart,
Shut Down.

Log Out shah.

Choose System Preferences... from the Apple menu.



SOoNn

Click on Users & Groups.



800 | Users & Groups.

Curnrem Waar

“ 0 | Change Password |

Otter Larn

O admin

Adman

') Cumst User Full name.  shah
Loghn, SPanng

]

Apple 1D Set...

Contacts Card: | Open.. |
 Nlow user to reset password using Apple 10
_LNSow user 1o administer thin computer

Click on the little padlock on lower left side.



n System Preferences is trying to wnlock Users &

o Growps preferences. Type an administrator’s

Put in the admin username and password and click Unlock.



80n | Users & Groups.

Curnrem Waar

B 0 [ Change Password... )

Other Laen
admin
Adrin e

) Guest User Full name.  shah

w Logn, Sharing

]

Apple 1D Set...

Contacts Card: | Open.. |
| Nlow user to reset password using Apple 10
| Niow user to administer this computer

.| Emable parental controls = Open Parenzal Controls...

- Oick the lock 10 prevent forther changes.

Click on the + sign.



NON Users & Croups
L L Show Al |

New Account Standard

Fu Name: teacherl

me'n Account name  teacher]

“. C“"“‘! Password  ssesnens

Verify 0.000004

'
d Ouck the lock 10 prevest frther changes.

Enter a username and password you’d like to use for this account. Normally | do all my work
in a standard account and only use the administrator account to install software or do other

administrative task. Better security this way.

Click Create User. If you see a message onscreen about automatic login, click Keep automatic
login.



¢

¥ Allow guests to log in to this compater
Crable the geest wser 50 that friends can temporarily log in 10 your
competer. Logging in to the guest account doet not reguire a
‘ Cunst User patyword. Uners cannct log in to the guest account remctely, or
Login, Sharing Fle Vauk iz turmed on.
When a guest wier logs out, al information and Ales in the
peeat accourt’s home folder are defated.

__Enable parental comtrols  Open Parental Controly...

i Allow guests to connect 10 shared folders

O Logn Options
¢~

d‘ Ouck the Jock 10 peevet farther changes.

Click on Guest account. Tick Allow guests to log in to this computer.

This is good for occasional users and for computer labs because everything you do will be
wiped when you log out.



enn Users & Croups

|« > || Snowal | Q

0 ;’:’;“ Autamanic logia 7 O |

Orhes shah

Q simn =, :

" Jociatt e T

“'Cuest User _ Show input meew i login window

o o Show password Rints

W Show fast user switching menu as  Full Name s
_ Use VoigeDwver n the login window

Qloo'nouiom

i
L‘ Oick the Jock 10 prevent further Changis ?

Click Login Options.

From the Automatic Login popup choose either your account of the guest account.



Curtem Waar

0 S

Oeter Laen
admin
Ad

teacherl
La~dars

Cuest User
n (ogin, Sharing

— ——— - —— - —

v Show the Skeep, Restart, and S5ut Down buttons
| Show Input menu in login window
V Show passwoed hints

v/ Show fast user switching menu as  Full Name

| Use VoiceOver in the login window

Network Account Server:  Join..

“wmu»muwm

You’ll need to put in the password and click OK.



eonN Users & Croups

Astomatic login: ;"u' acherl

Display login window as: (#) List of users
~ Name and password
: (¥ Show the Skeep, Restart, and St Down buttons
) Cuest User _ Show Input menu in login window
Login, Sharing GSM R
(¥ Show fast user switching menu as  Full Name
__ Use VoiceOver in the login window

=

¢ -

"mmw»wmwm

Here, the computer is set up to log directly into the teacherl account. Restart the computer
and it should log directly into the teacherl account.



|.2 Configure Trackpad



About This Mac
Software Update
App Store ...

Dock .
Recent ltems B

force Quit Finder L OXYD

Sleep
Restart.
Shut Down.

Log Out shah... oxXQ

Choose System Preferences... from the Apple menu.



SOoNn

lw ?

Ew i

Choose Trackpad.



.
'\ Point & O ‘ Scroll & Zoom ) L GCestures

8 Scroll direction: natural
Coaternt tracks Anger movernent

8 Zoom i or out
Poch wih two Hagens

e Smarnt zoom
Ooulsie 120 with two Argers

e m-munm

- Set Up Bloetooth Trackpead . (7

Review the Scroll & Zoom settings. You may wish to change the Scroll direction.



8eon Trackpad

. Set Up Bloetooth Trackpad .. | (7]

Click Point & Click. Change Tracking Speed to fast and make sure Tap to click is set. Tick
Three finger drag.



eon Trackpad

- Point & Cick  Scroll & Zoe

Swipe between pages
Scrof toft or Night with two Sngens »

o Swipe between full-screen apes
Swpe left o Pght with four Sogeny v

e Notification Center
Swipe ieft from Me rigt edge with twa Angens

emm

Swpe up with four fngers v

= App Exposé
Swioe down Wi lour Sngery v

g Launchpad
Prsth with Tl and thiee Pagers

o Show Desktop
SOrea] wih Thrdh avd thive Nagery

Click More Gestures. Tick App Expose. Close System Preferences when done by clicking the
Red button.



| .3 Mouse Basics



Click the Finder (lower left) to open a Finder window.



Double click the ‘About Downloads’ file to open it.



« About 1

D+ & Q| 2

Downloads Stack

The file is displayed. Notice that the application name at the top left of the screen has
changed to Preview.



Preferences... X, h

Services

Hide Preview ®H
Hide Others “UXH

Show Al
N .y

»

Quit Preview »0

Choose Quit Preview from the Preview menu. Notice the name at the top of the screen
changes back to Finder.



o Avap
iy Agplicati..
e DNskrop

T Decuments

O Dowelcads
| Mavies

-
Ju Music

L) Pxrures

emate

Drag About Downloads to the Desktop. Note that All My Files always shows you all the files
that belong to you, regardless of their location in the filesystem.



Compress “Abcut Domnioads”
Burn "About Downloads” to Disc..
Dupicate

Make Alias
Quick Look “About Downdoads”
Share

Copy “"About Downloads®

Clean Up Selection
Show View Optons

Right-click on About Downloads to show the contextual menu.



Clean Up

Clean Up By

Sort By

Show View Options

Right-click on Desktop to change Desktop pattern.



| 4 Create New Folder



Cet Info

Change Desktop Background...

Clean Up

Clean Up By .
Sort By :
Show View Options

Right-click on Desktop, choose New Folder.



You can type in the name immediately, no need to delete the existing text first.



After you type in the new name, my stuff, press Return (same place as Enter key).



Done. To change the name again press return, and repeat the process.



Double-click the newly created folder to open it.



Create a new folder inside it called lesson plans.



1.5 Copy Files



Select Startup Disk on Desktop

5 All My Flles
1 Documens

EA Desktop

O Downloads
D Home

% AirCrop
M Network
# Applications
- Unilives

Regemt Folders

Co to Folcer. ..
Connect 10 Server

Choose Computer from the Go menu to open a new Finder window.



Double click on Macintosh HD to show the contents.



Click Column View.



The contents of Macintosh HD are displayed in columnar format.



Click Library -> Desktop Pictures.

»
»
»
»
»
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»
>
»
»
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L. Al My Files
“F AirDrop
i Applicari...
s Desizop
" Documenms
) Downloacs
1 Movies

Je Music

L) Pclures

« ' Remote

»

-

-—
— "'.1 -

e Aceialtons
Wl Lisrary

Ul Sysiem

W Users

('\ .

ASphaton Supoet

Aude

Caches
ColorPlhans
Cbl)isy‘it
Componests
Comvpoindns

Comertudl Wenu tems

Deshacy Poures
Diaonanes
DireiorySeareCes
Documercinen
e 100
Fiesystens
forncs
Framewons
Craphcs

Image Casturs
Mol Nethads
MLemet g -nd
Tones

Drag Desktop Pictures to the my stuff folder.
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Open my stuff.

You should see lesson plans and Desktop Pictures in there.



M6 2012 126 MW
Today 353 MM

Click on List view button.

This view is most like Windows Explorer.



& Ducks on a Misty Poad oo
& Eagle & Waterfall Jog
B Earth and Moon j2g
5 Eanth Worizen jpg
= Bephantjpy

Z Ramingos jog

= Foating icejpg

= Floating Leaves jpg
| Forest is Mist jpg
s Froglpg

m Caaxy jpg

Dute Nodfes
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Jon 21,2012 358 AM
Jun 21,2012 358 AM
Jon 21,2012 358 AM
Jun 21,2012 358 AM
Jon 21,2012 358 MM
Jun 21,2012 358 AM
Jon 21,2012 358 AM
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Jun 21,2012 358 AM
Jun 21, 2012 358 AM
Jon 21,2012 355 AM
Jun 21,2012 358 AM
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Jon 21,2012 158 AM
Jun 21, 2012 358 AM
Jon 21,2012 158 AM
Jun 21,2012 358 AM

Click on the Triangle to the left of Desktop Pictures to show its contents.
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T @
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o AN My Files
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Click Cover Flow View, you’ll be able to preview the pictures inside.



Click icon view again.



1.6 Launchpad



Click on the LaunchPad icon in the Dock.



All your applications will appear. Click TextEdit.



| .7 Create New File



TextEdit launches. You'll see a white light under the TextEdit icon.



S Untbeg

Neww' Do ument

- DOptions »  KeepinDock

Il Al o n
Show Al Windows

HiCe

T

.

WO N Fince

If you right-click on TextEdit then you will see a menu, choose Keep in Dock so that the
TextEdit icon is always in the Dock.



e T
My 170 10 Japan

Type in a few sentences. You can try the following keyboard shortcuts.

Command-X Cut
Command-V Paste
Command-C Copy
delete Backspace
fn-delete Delete



my stuft

Click on the Desktop and locate the my stuff folder.



Open the my stuff folder.



Open the Desktop Pictures folder.
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Drag a picture into the TextEdit document. This is called ‘drag-and-drop’.



| .8 Auto Save and
Versions



Duplicate

Rename.

Move To..

Export as POF ...

Revert To »
Attach Files... OXA
Show Properties U XP
Page Setup... oxpP

Primg

Choose Save from the File menu.



Change the name to lesson plan 1.



Click on the black triangle in the box to expand the window.
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Click Column view. Choose Desktop, then click my stuff, then click lesson plans.

Click Save.
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Undo Drag

Reqo

Cut
Copy

u.‘, ' .
FasLe

Now let’s change the picture to another picture. If the last thing you did before saving was
dragging in the picture, choose Undo Drag from the Edit menu. Otherwise select the picture
and press the Delete key on the Keyboard.
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Drag in a new picture from the Desktop Pictures folder.
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¥ File

New

Open
Open Recent

Close
Save "
Duplicate
Rename
Move To...

Export as PDF. ..
Revert To

Attach Files. OXA

Choose Save from the File menu. A second version of the file will be saved.




NN -3 Rename. .. -

pp_popop b i NOWIS 2

. , Jupiicate T
.r - '\'Xk

- Srowse Al Versions. . <y

Move your cursor to the right of the file name, and you will see a small arrow appear. Click it
and choose Browse All Versions...



The previous versions of the file will be displayed to the right of the file. Click on the title of
the previous version of the document (behind the current version) to display it.



Click Restore.



0o » lesson plan 1
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The previous version of the document is restored. This works in TextEdit, Preview, Keynote,
Numbers and Pages. Microsoft Office does not support this yet.



B e File Edit
About TextEdit

Preferences... 38, |
Services > |

Hide TextEdit %H
Hide Others "\ 3&#H

- T \
\),'..'o.o. 211

Quit TextEdit ¥Q

Choose Quit from the TextEdit menu.



Open the lesson plans folder.



You can see the file you just saved there.



lesson plan | Open with TextEdn -2

Click on the file (don’t double click) and press space bar to preview it. This is called Quick
Look.



1.9 Arrange Files



Clean Up
Clean Up By
Sort By

Close all windows. Choose Show View Options from the View menu.



on $i2e. A x b
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Crd apacing:

Textalea: L2 |
Label pcamion:
(#) Bortom Rure

$tow item Irfo
M Shor icon greview
Soet by < Nome

Srap o Grd

Naree

Date Mo Bed
Date Created
Date Last Ozenes

About
Downloads

In the Arrange by pop up menu, choose Kind. All the icons on the Desktop will arrange
themselves on the right side of the screen. You can change other parameters as well. Close
the window when done.



.10 Find Files



9 £ = 4 @I Sun 4:41PM teacherl =

Press Command-Space to enable Spotlight.



Spotlight —

m‘

Top Hit lesson plan 1
11
Documents . lesson plan 1 \

Search for lesson plan.
It will be displayed while you are typing the name.



9 i = 4 @EF Sun4:42PM teacherl Mol

Documents = lesson plan 1

web Searches €9 Search Web for “my trip 10°
£9 Search Wikipedia for "my trip to”

Spotlight Preferences...

If you type in the words in that document, it will display the file.
Click Show All in Finder.



Search: All My Tiles
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Click the file to show it’s path. Close the search window when done.



.11 Copy to
thumbdrive



W Downioacs
L Movies

Je Music

) PClures

AN

Plug in your thumbdrive. Open the lesson plans folder. Your thumbdrive will appear in the
lower left corner of the window.
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FAVORUTES
w Al My Files
“ AirDrop
Iy Applicati...
. Deskzop
1 Documents
) Downloads
F Movies
Je Music
L Pclures

Mssan 2dan |

OEVICES
L Remote .
|4 KINCY =

Drag lesson plan 1 into your thumbdrive. Note: Only the latest version will be copied.



Click on your thumbdrive. You can see the file inside.



DEVICES

\ - ) Remote...
[N KINGY Q\

To safely remove the thumbdrive, click the Eject button, then pull out the thumbdrive.



.12 Delete files



Open the lesson plans folder. Double click on lesson plan 1 to open it.
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We’re going to make a Duplicate of this file, so as to have something to put into the Trash.
Click on the arrow to the right of the name, and choose Duplicate.



&l /

Name the duplicate “to be trashed” and press Return.



P B 2 L8 File Ednt Form
About TextEdit

Preferences.. ot

Services >

Hide TextEcit XH
Hide Others UX¥H

Quit TextEdit.



wsson pian 1

Open the “lesson plans” folder. Notice a copy of the “lesson plan 1” file, named “to be
trashed”, appears in the lesson plans folder.



Drag lesson plan 1 to the Trash.

o .

-
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-
L ™

- -
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Note the Trash icon changes. Double click on it.



1o be trashed

The contents of the Trash folder is displayed. Click the Empty button to Empty the trash. If
you put things into the Trash by accident, drag it back out.



About Finder

Preferences

Secure Empty Trash. ..

Services

Hice Fincer
Hice Others

You can also choose Empty Trash from the Finder menu.



| .13 Install Printer
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The Mac can autodetect most printers, but if your printer doesn’t work you will need to
download the driver from the Internet first.



10 mac b L.LJ

o

Downloads
IT | B print_driver_for_10.6.zip

0
] -

1, T4 '
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<

Wait for the download to complete.



een in Finder

mnstalier for 1065

\

LN

Click Downloads in the Dock, you will see the printer driver there. Click it.



“Installer for 106" is an appiication downloaded

from the Internel. Are you sure you want 10 open
i?

WedPvooess Gownioaded ths Mle today a1 11 21 PN Spm

Click Open.



installer for 10.6 wants 10 make changes, Type
an administrator’s name and password 1o

Hj"'"""

Type in your admin username and password, and click OK.



@ Introduction

® Instalistion Type
® Imstalling

@ Finah Up

SAMSING SIGT.)

GO poweted by WOE X

Click Continue.



Click Install.

@ Introduction

& Installation Type
® Installing

@ Finah Up

ANVIAS Wiwen

m Installs
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- Co Back




@ Introduction

& Installation Type
® Installing

® Finah Up

Items remaining to be instaled:

-u--- — ——— -

Installing: Easy mwl

AN Wiwer

— Installation
m |

SRR ERRE N it
o powered by WO X

Wait until installation completes.



Finish Up

Iestallation was successtul. Iif you are finished, dlick Quit 16 leave
the installer. If you wish to perform additional imstallations, click |
Contirue.

ANVIAS Wiwen

- Instaliation
m ,

IR R R N R R )
T On powmeted by WOE X

Click Quit.



.14 Print file



About
Downloads

Open the file you want to print.



41"8 Edit - Lo
Q O 0 New trom Clipboard =N

) v "“' Open, . =0
= Dpen Recent >

Close Windaw =W
Close Selected POF Document O XW
Save, =5
Dunlicate ) 43
Rename,
Move To.,
Expon.
Revert To »
Frter Password

i non :.-:o['. 11..”,"0 J
Imoort rom Scanne

Take Screen Shee v

Choose Print from the File menu.



Printet v A No Printer Selected |

-
Copies

Print & Scan Preferences...

Pages:|"AIl e

If you see No Printer Selected click Add Printer...

You'll need the administrator username and password to Add Printer.



Name: Samsung CLP-510-2
Print Using: = Samsung CLP-510

Choose the printer and click Add.
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Click Show Details to see advanced print options.
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The advanced print options are displayed.
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Note that you can save the document as a PDF as well.
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Click Print to print the document.



When printing starts you will see the Print Queue in the Dock. Click it.



This shows you printer status and jobs waiting to be printed.



